A lot of script-driven apps, particularly paid cms, encode their files in order to make sure that they won't be reverse engineered or tampered with. Many of them use an application named ionCube PHP Encoder to do that, so, in case you obtain a paid script and you want to set it up in a hosting account, a tool known as ionCube Loader has to be present on your server. Without having it, you cannot install the script or if you somehow manage to do this, it will not operate appropriately for the reason that almost all of the script code will be encoded to a point where it can't be interpreted. That is why, you have to make sure that ionCube Loader is set up when you get a fresh website hosting account and you would like to take advantage of some paid web app. If you obtain a shared hosting account and the tool is not present, it cannot be added since the entire server PHP environment shall have to be compiled again.
IonCube in Cloud Hosting
IonCube Loader is present on all the web servers that are a part of our cloud hosting platform, which means that irrespective of the cloud hosting that you choose during the signup process, you can activate it through the Hepsia Control Panel. This process is as simple as right-clicking an On/Off button from the Advanced section, so even if this is your first hosting account ever, you will not need to do anything complicated. The same section will allow you to pick the PHP version for your account (4, 5.2, 5.3, 5.4, 5.5), which means that in case you decide to switch to some other version, you only need to activate ionCube Loader for it too. Since our platform is rather flexible, you can even set a different PHP version and a different status of ionCube by employing a php.ini file in each domain folder. If this is something you'd like to do but you do not have much experience, the 24/7 technical support team shall help you very quickly.
IonCube in Semi-dedicated Servers
In case you obtain a semi-dedicated server plan from our company, you can employ any kind of script-driven app that requires ionCube Loader because the tool is available on all of the servers that are part of our modern cloud web hosting platform. In addition, we support multiple releases of PHP, which means that if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for that particular version with only a click from your Hepsia Control Panel. Our system will remember your decision, so in case you switch back to the earlier release of PHP, the software tool will already be active. For more tech-savvy users, we also provide the option to pick the PHP version and if ionCube will be active or not for a specific domain name without altering the settings for the whole hosting account. This is done by putting a php.ini file in a domain folder with a few lines of program code.